Error SetupArrayProps_R: array prop '(null)' is at index zero

Hello everyone, I’m new at hl2 mods, and I don’t know exactly what to do when an issue comes up. So, the problem is, that whenever I start BM : S from Steam, it opens up and keeps loading, but, after 2~4 seconds it closes and a message pops up: “Engine Error: SetupArrayProps_R: array prop ‘(null)’ is at index zero.”.
Well, that’s it, I need so much help, I really want to play this game, reply as soon as you know how to fix this suffocating problem.

(I installed SDK Base 2007, changed appID to 218 (it was 218 anyways), restarted steam, reinstalled, deleted bin, download BM : S again, and I couldn’t do more …) Just to let y’all know …

Thanks for reading.

I’m having the same issue. I’ve been going through some Valve troubleshooting steps (verified the game cache of the SDK, attempted to run it to reset the game configuration (as advised here)), and I’ve started on the basic stuff (Steam Supports’ Troubleshooting Game Crashes) though I suspect half of this is irrelevant. I’m getting nowhere.

*It was working fine for the last day or two

*When I try to run the SDK as mentioned above, it gets past the two logo screens to the pre-menu loading screen with a blurry background, and then it crashes before reaching the menu with the same error as BM.

Yes yes, same problem here. i just bought Portal 1, and decided to play some more Black Mesa while it downloads and now i have this problem. i cannot solve it. What are we supposed to do?

So i played Black Mesa a few hours. when i went back to start BM this error came:

SetupArrayProps_R: array prop ‘(null)’ is at index zero

So when i start the game, it crashes…

So i have tried to search on Google, but i really need an easy explaination how to solve it, anyone?

I’ve got this error cropping up, too. I was playing earlier today with no problems. Now, bang. Won’t start.

I might be the only one but I did have a weird client update with no details specified (changelog etc.) when I started Steam today. Mind you, nearly everytime I start Steam it seems to be completing an update.

Everything has been working fine till I saved the game at the point where you turn off the electric fence in Surface Tensions. I saved the game and exited. When I went back to play it, the screen flashed and then shows me a error message saying “SetupArrayProps_R: array prop ‘(null)’ is at index zero”. I’m at a loss for what I should do and I don’t want to lose my game data or possibly have to reinstall the software so is they anyone who can help me with this issue?

Merging this thread as there is already one with the same error.

Can’t test right now as I’m working but it does seem like a recent Steam update has somehow broken the mod. Please bear with us while this is looked into.

I am also getting this error. It was working fine yesterday when I was playing it but no luck today.

I noticed a Source SDK base 2007 update come though today when I started steam and I think this is likely the cause of the issue because if I try to open the Source SDK base 2007 tool in order to run the video test it also crashes with the same error: “SetupArrayProps_R: array prop ‘(null)’ is at index zero.”

I haven’t found a way to resolve it yet either :frowning:


If I set the Source SDK base 2007 to not automatically update in the properties, then restore it from a backup both it, and the Black Mesa mod start working again and I am able to play as normal. :slight_smile:

I confirm that I just got this as well. Hopefully Valve fixes this.

Heeeelp … got the same problem BUT

I cant find the settings menu…where I can change these settings with SDK!

“If I set the Source SDK base 2007 to not automatically update in the properties, then restore it from a backup both it, and the Black Mesa mod start working again an”

Trying to load the Source SDK Base 2007 directly seems to result in the same error. I suspect we will have to wait on VALVe to push out a fix for this Issue since my attempts to resolve it so far have proven to be elusive.

For non-geeks like me can somebody provide a step by step procedure to get BM running again? Thanks.

Step 1. Wait for Valve to fix the problem.
Step 2. Play Black Mesa.

but where can i change these settings:

"“If I set the Source SDK base 2007 to not automatically update in the properties,…”

Lol I just finished watching Husky playthrough today and decided to install Black Mesa. Got everything done and have this problem so google led me here. How unfortunate!

Joining the long list of those who are waiting for the fix. Today it has been a update and it has broken the game for me.

This is unbearable!

I have been putting off Black Mesa installation for months.

I didn’t even have Steam installed on this machine as I have not played ANY games for a couple of years.

For some Karmic reason, I chose today to download and install both Black Mesa and the Source SDK.


Hey people :frowning:
Same here, I just came from university, wanted to play a bit Black Mesa and before launching the game I saw a litle update of Black Mesa… After this I could not play anymore
And yea, I either can start source sdk base 2007, it crashes before playing :confused:

Founded in 2004, became one of the first online communities dedicated to Valve’s Source engine development. It is more famously known for the formation of Black Mesa: Source under the 'Leakfree Modification Team' handle in September 2004.